Follow

What are the Latch app´s technical requirements?

The app is available for these operating systems and versions:

-       iOS 6 and iOS 7

-       Android 4 and above

-       Windows Phone 8

In unofficial operating system versions some Latch features may not work properly.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk